配置在这里
R1
!
interface Loopback1
ip address 172.16.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.12.1 255.255.255.0
duplex auto
speed auto
!
router eigrp 100
network 172.16.0.0
network 192.168.12.0
no auto-summary
!
R2
!
interface Serial0/0
ip address 192.168.23.2 255.255.255.0
serial restart-delay 0
!
interface Serial0/1
ip address 192.168.24.2 255.255.255.0
serial restart-delay 0
!
interface Serial0/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet1/0
ip address 192.168.12.2 255.255.255.0
duplex auto
speed auto
!
router eigrp 100
redistribute rip metric 2000 100 255 1 1500
redistribute ospf 1 metric 2000 100 255 1 1500
network 192.168.12.0
no auto-summary
!
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
redistribute eigrp 100 subnets
network 192.168.24.2 0.0.0.0 area 0
!
router rip
version 2
redistribute eigrp 100 metric 1
network 192.168.23.0
no auto-summary
R3
!
interface Serial0/0
ip address 192.168.23.3 255.255.255.0
shutdown
serial restart-delay 0
!
interface Serial0/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet1/0
ip address 192.168.100.3 255.255.255.0
duplex auto
speed auto
!
router rip
version 2
passive-interface FastEthernet1/0
network 192.168.23.0
network 192.168.100.0
neighbor 192.168.100.5
no auto-summary
!
R4
!
interface Loopback1
ip address 172.16.4.1 255.255.255.0
!
interface Serial0/0
ip address 192.168.24.4 255.255.255.0
serial restart-delay 0
!
interface Serial0/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet1/0
ip address 192.168.100.4 255.255.255.0
duplex auto
speed auto
!
router ospf 1
router-id 4.4.4.4
log-adjacency-changes
redistribute static subnets
network 192.168.24.4 0.0.0.0 area 0
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
ip route 172.16.64.0 255.255.252.0 192.168.100.5
R5
!
interface Loopback1
ip address 172.16.65.1 255.255.255.0
!
interface Loopback2
ip address 172.16.66.1 255.255.255.0
!
interface Loopback3
ip address 172.16.67.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.100.5 255.255.255.0
duplex auto
speed auto
!
router rip
version 2
redistribute connected metric 1
passive-interface default
network 192.168.100.0
neighbor 192.168.100.3
no auto-summary
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
ip route 172.16.1.0 255.255.255.0 192.168.100.4 130
!
!