Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#user R2 pass aaa
R1(config)#int s 0/0/0
R1(config-if)#ip add 192.168.1.1 255.255.255.0
R1(config-if)#no shut
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down
R1(config-if)#en ppp
R1(config-if)#ppp auth pap
R1(config-if)#exit
R2配置:
interface Serial0/0/0
ip address 192.168.1.2 255.255.255.0
encapsulation ppp
ppp authentication pap
ppp pap sent-username R2 password 0 aaa
clock rate 64000
紫川凌 发表于 2012-12-2 12:57
ppp authentication pap
表示启用PAP认证 你在R2上也开启了 这就变成双向了
把R1的封装取消了还是ping不通,这是啥情况啊?
R2
interface Serial0/0/0
ip address 192.168.10.2 255.255.255.0
encapsulation ppp
ppp authentication pap
ppp pap sent-username R2 password 0 aaa
clock rate 64000
Router>
Router>
Router>en
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#user R2 pass aaa
R1(config)#int s0/0/0
R1(config-if)#ip add 192.168.10.1 255.255.255.0
R1(config-if)#no shut
en
conf t
username spoto password cisco
int s0/0
ip address 12.12.12.1 255.255.255.0
encapsulation ppp
ppp authentication pap
no sh
exit
R2:
enable
conf t
int s0/0
ip address 12.12.12.2 255.255.255.0
encapsulation ppp
ppp pap sent-username spoto password 0 cisco
no sh
exit
!
!
=================PAP双向认证=================
en
conf t
username spoto password cisco
int s0/0
ip address 12.12.12.1 255.255.255.0
encapsulation ppp
ppp authentication pap
ppp pap sent-username ccna password 0 ccnp
no sh
exit
R2:
enable
conf t
username ccna password ccnp
int s0/0
ip address 12.12.12.2 255.255.255.0
encapsulation ppp
ppp pap sent-username spoto password 0 cisco
no sh
exit
=================PPP chap 单向认证=================
R1:
en
conf t
username spoto password cisco
int s0/0
ip address 12.12.12.1 255.255.255.0
encapsulation ppp
ppp authentication chap
no sh
exit
R2:
enable
conf t
int s0/0
ip address 12.12.12.2 255.255.255.0
encapsulation ppp
ppp chap hostname spoto
ppp chap password cisco
no sh
exit
=================CHAP双向认证=================
R1:
en
conf t
username R2 password spoto
int s0/0
ip address 12.12.12.1 255.255.255.0
encapsulation ppp
ppp authentication chap
no sh
exit
R2:
enable
conf t
username R1 password spoto
int s0/0
ip address 12.12.12.2 255.255.255.0
encapsulation ppp
ppp authentication chap
no sh
exit