帧中继基础知识总结(完美傻瓜版)
1 帧中继基本配置
1.1 帧中继交换机
帧中继交换机在实际工程环境中一般不需要我们配置,由运营商设置完成,但在实验环境中,要求掌握帧中继交换机的基本配置。配置示例:
frame-relay switching
interface s0/1
encapsulation frame-relay
frame-relay intf-type dce
clock rate 64000
frame-relay route 102 interface s0/2 201
// 定义PVC,该条命令是,s0/1口的DLCI 102,绑定到s0/2口的201 DLCI号
frame-relay route 103 interface s0/3 301
no shutdown
1.2 环境1 主接口运行帧中继(Invers-arp)
FRswitch(帧中继交换机)的配置:
frame-relay switching
interface s0/1 // 连接到R1的接口
encapsulation frame-relay
frame-relay intf-type dce
clock rate 64000
frame-relay route 102 interface s0/2 201
// 定义PVC,该条命令是,s0/1口的DLCI 102,绑定到s0/2口的201 DLCI号
no shutdown
interface s0/2 // 连接到R2的接口
encapsulation frame-relay
frame-relay intf-type dce
clock rate 64000
frame-relay route 201 interface s0/1 102
no shutdown
R1的配置如下:
interface serial 0/0
ip address 192.168.12.1 255.255.255.252
encapsulation frame-relay
// 接口封装FR,通过invers-arp发现DLCI,并建立对端IP到本地DLCI的映射(帧中继映射表)
no shutdown
R2的配置如下:
interface serial 0/0
ip address 192.168.12.2 255.255.255.252
encapsulation frame-relay
no shutdown
在FRswitch上查看PVI(验证配置):
FRswitch#show frame-relay route
Input Intf Input Dlci Output Intf Output Dlci Status
Serial0/1 102 Serial0/2 201 active
Serial0/2 201 Serial0/1 102 active
在R1上查看帧中继映射
R1#show frame-relay map
Serial0/0 (up): ip 192.168.12.2 dlci 102(0x66,0x1860), dynamic,
broadcast,, status defined, active
R1#ping 192.168.12.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.12.2, timeout is 2 seconds:
!!!!!
1.3 环境2 主接口运行帧中继(静态映射)
FRswitch的配置同上,这里不再赘述
上述案例是终端路由器采用动态invers-arp获取帧中继相关映射信息,本例采用静态建立映射的方式进行配置。
R1的配置:
interface serial 0/0
ip address 192.168.12.1 255.255.255.252
encapsulation frame-relay
no frame-relay inverse-arp // 关闭动态inverse-arp,可选
frame-relay map ip 192.168.12.2 102 [broadcast]
// 建立静态帧中继映射,注意,这里是低端的IP到本地DLCI的映射
// 使用该命令,建立的PVC将不支持广播(如此,依赖广播或组播运行的动态路由协议跑在此链路
上就可能存在问题),可在该条命令后增加broadcast关键字,使PVC支持广播。
R2的配置:
interface serial 0/0
ip address 192.168.12.2 255.255.255.252
encapsulation frame-relay
no frame-relay inverse-arp // 关闭动态inverse-arp,可选
frame-relay map ip 192.168.12.1 201 [broadcast]
查看R1的帧中继映射:
R1#show frame-relay map
Serial0/0 (up): ip 192.168.12.2 dlci 102(0x66,0x1860), static,
broadcast,
CISCO, status defined, active
注意,采用静态FR映射,建立的PVC如果不加broadcast关键字,则链路不支持广播。
由于帧中继网络是NBMA(非广播型多路访问)网络,因此无法支持广播,但帧中继提供一种机制来模拟广播,基本上是采用向每条PVC发送一个该帧的拷贝来实现。
许多动态路由协议均需要广播或组播传输机制的,RIP、EIGRP、OSPF等,因此如果在帧中继上运行这几种协议,就可能会出现问题,这时候就需要使用到上面的特性,具体的操作方式是在map语句后加上broadcast关键字。
frame-relay map ip 192.168.12.1 201 broadcast
|