雏鹰部落

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
查看: 4419|回复: 25

【BOOTCAMP入学准备之二】CCNA知识归纳总结

  [复制链接]
发表于 2011-4-24 02:40:53 | 显示全部楼层 |阅读模式
本帖最后由 薯薯 于 2011-5-25 17:09 编辑

    本帖针对学习完CCNA的学员,并在进入SPOTO自主研发的BOOTCAMP实战课程之前,进行一些必要的知识储备,以让各位学员可以更快地投入BOOTCAMP的学习,请各位学员重视此次学前准备,因为BOOTCAMP课程强度是比较大的,刚学习完CCNA的学员可能会不好适应。希望不管您是否在SPOTO学习过CCNA,在学习过本帖之后都将会有所收获。
    注意:本帖推荐阅读方式:耐心地边看边学,遇到不理解的地方可以记下,具体操作方法或理论在BOOTCAMP阶段将会再介绍。
   
    本系列总共分四个部分:
    第一部分:常用软件安装与使用
    第二部分:CCNA理论知识总结
    第三部分:LAB能力提升
    第四部分:BOOTCAMP实验室的使用

////////////////////////
////    第二部分     ////
////////////////////////

      


本节内容感谢 Tutor-潘HD 倾情整理


一、简单的路由排错

若PC1 Ping 不通PC2 排错步骤如下:

1、检查下PC1端口IP地址是否配置正确,用show ip route 查看是否PC1上有关闭路由功能。

2、在PC1上Ping 它的网关,看是否能Ping 通,若不能,则检查下R1 在F0/0端口的IP地址是否配置正确。

3、在R1上用show ip route 查看是否有去往PC2的路由条目,若无,则添加一条去往PC2的路由条目。这里可以用默认路由,因为只有一个出接口。

4、在R2上用show ip route 查看是否有去往PC2的路由条目,若无,则添加一条去往PC2的路由条目。这里最好不要用默认路由。

5、检查下PC2端口IP地址是否配置正确,用show ip route 查看是否PC2上有关闭路由功能。

6、在PC2上Ping 它的网关,看是否能Ping 通,若不能,则检查下R3 在F1/0端口的IP地址是否配置正确。

7、在R3上用show ip route 查看是否有去往PC1的路由条目,若无,则添加一条去往PC1的路由条目。这里可以用默认路由,因为只有一个出接口。

8、在R2上用show ip route 查看是否有去往PC1的路由条目,若无,则添加一条去往PC1的路由条目。同样的,这里最好也不要用默认路由。

这样一步步,就能检查出,那里出错啦。

在这里简单说明下Ping不通出现的以下两种情况:

1、U.U.U出现U的情况,说明不可达,这说明是去不了,在出的路上就出现了问题。

2、…..出现5个点的情况,这时候有两种情况:①连网关都Ping不通,这时候就出现这种情况。②数据包可以到达PC2,到是回不来,这时候也出现这种情况。

二、使用模拟器时,出现很卡,CPU一直是100%的情况

      通过计算idle pc值,来降低CPU使用率。并不是每台电脑只要计算一次的idle pc值,当我们做实验的时候,出现需要有较多太路由器时,同时开启路由器后,发现很卡,就需要计算idle pc值,选择打星号,后面数值较大的那个idle pc值比较合理。

三、关于vty的一些注意点

     首先,若一台路由器需要被远程登入时需要配置vty密码,配置密码有两种方式,一种是需要验证的,一种是不需要验证的。

需要验证的:

line vty 0 4
Password spoto
Login

这样的话,当这台路由器被远程登录时,需要输入密码,吻合了才可以登录。
不需要验证的:line vty 0 4

Password spoto
no Login

这样的话,当这台路由器被远程登录时,不需要输入密码就可以登录。

这里要记得,一定要加login或no login 中的一种,否则vty相当于没设。

另外一点,配置了vty密码后,被远程登录,只是登录到了用户模式,若要登录到特权模式,要需要配置enable密码。

四、RIP与EIGRP发布时的注意点

Router rip
Version 2
No auto-summary
Network 10.0.0.0
Network 172.16.0.0
Network 192.168.10.0

     这里需要注意的地方是,发布时,A类地址至只写前8位的值,后面24位都为0,B类地址要写至少前16位的值,后16位用0,C类地址要写前24位的值,后8位用0.
    以前发现有的学员出现这样的问题,C类的地址,发布时和A类地址一样,只写前8位,后来相邻的路由器一直学习不到路由条目。
    EIGRP发布也是同样的道理,不过EIGRP可以后面加上反掩码,实现精确发布。

五、OSPF中DR,BDR的选举问题

     在以太网中,那台路由器成为DR,没有任何的影响。而在帧中继中,一般,在整张拓扑图中最重要的,连通整张拓扑的那台路由器,我们通常把它设为DR。

那么如何让这台最重要的路由器成为DR呢?有以下两种方法:

1、改变端口优先级,端口优先级高的成为DR。一般情况下,端口的优先级默认都为1,若想要将某台路由器设为DR,那么可以进入这台路由器的端口,修改其优先级,命令如下:

Int f0/0
Ip ospf priority number (number的取值范围为0-255 若设为0,则不参与DR的选举)
Exit

2、修改R-ID

① 首先,可以手动配置R-ID,命令如下:

Router ospf 100
Router-id 1.1.1.1

    若有手动配置R-ID,则这台路由器的R-ID的值即为该值(注意:手动配置R—ID可以是不存在的地址,但是必须全网唯一)

② 其次,若无手动配置R-ID,则看看有没有配置环回接口即Loopback口,若有,则选择Loopback口IP值最高的为路由器R-ID。

③ 最后,若也无Loopback,则看活跃物理接口的IP地址(即看看哪些端口是双UP的),比较双UP的端口的IP值大的为路由器R-ID。

在优先级相同的情况下(先比较优先级),比较路由器的R-ID值,R-ID值大为DR。选完DR,次优的为BDR。

六 、交换机远程管理问题


方法一:实验书上介绍

PC1远程管理交换机

Sw1(conig)#no ip routing
Sw1(conig)#interface vlan 1
Sw1(conig-if)#ip add 172.16.10.1 255.255.255.0
Sw1(conig)#ip default-gateway 172.16.10.254
Sw1(conig)#line vty 0 4
Sw1(conig-line)#password spoto
Sw1(conig-line)#login
Sw2(conig)#no ip routing
Sw2(conig)#interface vlan 1
Sw2(conig-if)#ip add 172.16.10.2 255.255.255.0
Sw2(conig)#ip default-gateway 172.16.10.254
Sw2(conig)#line vty 0 4
Sw2(conig-line)#password spoto
Sw2(conig-line)#login
R1(config)#int f0/0.1
R1(config-subif)#encapsulation dot1q 1
R1(config-subif)#ip add 172.16.10.254 255.255.255.0

PC1远程登入SW1、sw2

PC1#telnet 172.16.10.1
PC1#telnet 172.16.10.2

方法二:

PC1远程管理交换机

Sw1(conig)#no ip routing
Sw1(conig)#interface vlan 10
Sw1(conig-if)#ip add 10.10.10.253 255.255.255.0
Sw1(conig)#ip default-gateway 10.10.10.254
Sw1(conig)#line vty 0 4
Sw1(conig-line)#password spoto
Sw1(conig-line)#login
Sw2(conig)#no ip routing
Sw2(conig)#interface vlan 10
Sw2(conig-if)#ip add 10.10.10.252 255.255.255.0
Sw2(conig)#ip default-gateway 10.10.10.254
Sw2(conig)#line vty 0 4
Sw2(conig-line)#password spoto
Sw2(conig-line)#login

PC1远程登入SW1、sw2

PC1#telnet 10.10.10.253
PC1#telnet 10.10.10.252

注意观察这两种方法的区别,不同的地方已经标志出来,自己体会下。

七、交换机配置VTP注意点

1、需相互学习的交换机,VTP的域名要设置相同

2、必须有一台交换机的模式是服务器模式(mode server)默认是服务器模式

3、VTP是Cisco私有的,只有在Cisco的路由器上才可以进行配置
     在模拟器上可以在特权模式下进行vlan的配置,也可以在全局模式下进行配置,现在都建议在全局配置模式下进行vlan的配置。

4、VTP的三种模式,①server模式②client模式③transparant透明模式
区别:
server模式:可以进行vlan的创建,删除,修改,传递,学习
Client模式:只能进行传递,学习。不可以创建,删除
Transparent模式:可以进行vlan的创建,删除,修改,但这些操作只是对于自己而言(只是具有本地意思,不影响整个VTP的域),还可以传递,但不学习。

注意点一:整个VTP的域中,至少要有一个server模式的交换机。
注意点二:server模式的版本号高的认为整个VTP域中信息最新,大家都跟这台最新的同步vlan信息,查看版本号的命令:show vtp status 其中Configuration Revision 即为版本号信息,数字高的为最新版本。创建或删除vlan时,版本号加一。

八、多层交换机配置

多层交换机和单臂路由可以实现不同VLAN之间的通信。这里介绍下多层交换机的配置。


可以在MSW1或MSW2上任意一台进行配置,这里假设在MSW1上:

En
Vlan datebase
Vlan 10 name vlan 10
Vlan 20 name vlan 20
Vtp domain spoto
Exit

Conf t
Int f0/1
switchport mode trunk
exit

int f0/0
switchport mode access
switchport access vlan 10
exit

int vlan 10
ip add 10.10.10.254 255.255.255.0
exit

int vlan 20
ip add 10.10.20.254 255.255.255.0
exit

可以用show vtp status 查看VTP的信息。
用同样的,在MSW2上设置VTP的域名为spoto,把PC2划入vlan 20

最重要的地方: 把PC1 和PC2 的网关都设置在同一台多层交换机上。

九、ACL注意点

1、ACL可能会过滤路由更新包,所以要配置ACL允许更新包,保证路由正常。
比如:运行OSPF路由协议时:
Acces-list 101 permit ip x.x.x.x  x.x.x.x  x.x.x.x  x.x.x.x
Access-list 101 permit ospf any any (要加上这条,否则路由器之间发现不了邻居)

2、配置ACL时,默认最后加上deny any any
如果只是不允许特定的源IP,那么先写不允许的,再写permit any
ACL的读取顺序是从上往下的,要修改或插入 只能重新配置ACL。

3、在全局模式下定义内容,在接口下应用(这里注意方向)
在接口下应用,方向问题,根据源IP——》目的IP的方向,在设置in 或out

4、一般情况下,配置标准ACL,在接近目的IP路由器上进行ACL的应用,而配置扩展ACL,在接近源IP的路由器上进行应用。

十、NAT注意点

1:若使用单臂路由时,指明内网时,要在子接口下指明。
如:
int f0/0.10
Ip nat inside

而不是:
Int f0/0
Ip nat inside

2:配置静态NAT时,

Ip nat inside source static 10.10.10.1  211.1.1.2
这里的211.1.1.2必须与外网的那个端口的IP同一网段。

3:静态端口映射:

Ip nat inside source static tcp 10.10.10.1 80 int f0/0 80
这里的10.10.10.1 是内网的服务器的IP,对外提供HTTP服务
这里的int f0/0 可以写成它的IP地址形式,外网通过访问int f0/0 的IP,来访问内网服务器。



以下为参考资料

头点什么-33页CCNA学习笔记:

一份笔者推荐的129页CCNA精解,推荐有时间的同学可以下来看看:






该贴已经同步到 薯薯的微博

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
发表于 2011-4-24 07:30:52 | 显示全部楼层
沙发云鹏辛苦了...
发表于 2011-4-24 09:23:40 | 显示全部楼层
LZ很有经验 ,总结得非常好呀。
发表于 2011-4-24 11:09:04 | 显示全部楼层
回复 2 # Vneng 的帖子

SN同学 你好拉风哦~
 楼主| 发表于 2011-4-24 11:11:07 | 显示全部楼层
回复 3 # roy 的帖子

还行还行,引用居多,多谢支持嘿嘿
发表于 2011-4-24 11:59:38 | 显示全部楼层
我收了,多很多学CCNA的学员很有用的!
发表于 2011-4-24 14:16:31 | 显示全部楼层
辛苦了,一个人要写这么多篇帖子
发表于 2011-4-24 14:48:16 | 显示全部楼层
呵呵,让102班的同学来看看咯
发表于 2011-4-24 14:54:48 | 显示全部楼层
辛苦了呀
发表于 2011-4-24 16:24:58 | 显示全部楼层
果断顶      
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|熊猫同学技术论坛|小黑屋|网络工程师论坛 ( 沪ICP备09076391 )

GMT+8, 2022-7-7 13:06 , Processed in 0.056719 second(s), 19 queries , Gzip On.

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表