interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 12.12.12.1 255.255.255.0
shutdown
duplex auto
speed auto
!
no ip http server
no ip http secure-server
!
ip route 12.12.12.0 255.255.255.0 1.1.1.1
!
--------------------------------------------------------
R4配置
!
!
interface FastEthernet0/0
ip address 1.1.1.1 255.255.255.0
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 12.12.12.2 255.255.255.0
shutdown
duplex auto
speed auto
!
no ip http server
no ip http secure-server
!
ip route 1.1.1.0 255.255.255.0 12.12.12.1
!
----------------------------------------------------------
你那个R3..没有添加FastEthernet1/0模块 我给添加了个 然后导入了你这些配置..
看你的配置 应该是想在R3上面的fa1/0给个IP为1.1.1.1
在R4的fa0/0给个IP为2.2.2.2
然后在R3做个静态路由指向R4的 2.2.2.2
在R4做个静态路由指向R3 1.1.1.1
那配置应该如下的
----------------------------R3
R3>
en
conf t
int fa 0/0
ip add 12.12.12.1 255.255.255.0
no shut
int fa 1/0
ip add 1.1.1.1 255.255.255.0
no shut
exit
ip route 2.2.2.0 255.255.255.0 12.12.12.2
end
------------------------------------------R4
R4>
en
conf t
int fa 1/0
ip add 12.12.12.2 255.255.255.0
no shut
int fa 0/0
ip add 2.2.2.2 255.255.255.0
no shut
exit
ip route 1.1.1.0 255.255.255.0 12.12.12.1
end
R3:
interface FastEthernet0/0 //这个接口应该才是和R4连接的接口吧?没有配IP
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0 //这个接口图上不存在
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
!
no ip http server
no ip http secure-server
!
ip route 12.12.12.0 255.255.255.0 1.1.1.1 //此处的静态路由写错了,目的网段是要去哪里?1.1.1.1?那下一跳应该是12.12.12.2
R4
interface FastEthernet0/0
ip address 1.1.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0 //这个是和R3连接的接口
ip address 12.12.12.2 255.255.255.0
duplex auto
speed auto
!
no ip http server
no ip http secure-server
!
ip route 1.1.1.0 255.255.255.0 12.12.12.1 //静态路由格式:ip route +目的网段+掩码+下一跳/出接口