Building configuration... Current configuration : 1396 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool MinBoo
network 192.168.1.0 255.255.255.0
dns-server 202.106.0.20
default-router 192.168.1.1
lease infinite
!
!
no ip domain lookup
multilink bundle-name authenticated
vpdn enable
!
vpdn-group MinBoo
request-dialin
protocol pppoe
l2tp tunnel receive-window 1024
!
!
!
archive
log config
hidekeys
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
pppoe enable
pppoe-client dial-pool-number 1
!
interface FastEthernet0/1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface Dialer1
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp pap sent-username 400000037435 password 0 s4w8v5h8
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
!
!
no ip http server
ip nat inside source list 1 interface Dialer1 overload
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
end
贴一个SPOTO上海曾经用过的在路由器上配置PPPoE的case,网络使用情况良好。
SPOTO-C3640#show run
Building configuration...
Current configuration : 952 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SPOTO-C3640
!
boot-start-marker
boot-end-marker
!
logging snmp-authfail
enable password cisco
!
no aaa new-model
!
!
ip cef
!
!
vpdn enable
!
vpdn-group 1
request-dialin
protocol pppoe
!
!
!
!
!
interface FastEthernet2/0
ip address 192.168.100.254 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet3/0
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Dialer0
ip address negotiated
ip nat outside
ip mtu 1492
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp pap sent-username ad19830604 password 0 SHspoto
!
ip http server
ip route 0.0.0.0 0.0.0.0 Dialer0
!
!
ip nat inside source list 1 interface Dialer0 overload
!
access-list 1 permit any
!
!
control-plane
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
password cisco
login
!
end
SPOTO-C3640# sh ip int brief
Interface IP-Address OK? Method Status Protocol
FastEthernet2/0 192.168.100.254 YES manual up up
FastEthernet3/0 unassigned YES manual up up
NVI0 unassigned NO unset up up
Virtual-Access1 unassigned YES unset up up
Virtual-Access2 unassigned YES unset up up
Dialer0 116.232.164.252 YES IPCP up up
SPOTO-C3640#wr
Building configuration...
[OK]