|
R2、R3为PE,运行的IGP是RIP。
PE-CE之间是静态路由。
配置是参考这里的: http://hi.baidu.com/skygogogo/blog/item/9ec2ee3bd111f6fa14cecb6b.html
现在的问题是PE-CE之间是通的,但是PE-PE之间不通,不知道问题出在哪了,请指教!:
R2#ping vrf A-company 4.4.4.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 44/107/144 ms
R3#ping vrf A-company 5.5.5.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/115/208 ms
R3#ping vrf B 6.6.6.6
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/64/116 ms
R2#ping vrf A-company 35.1.1.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 35.1.1.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R1的配置:
!
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface Loopback1
ip address 202.96.134.133 255.255.255.0
!
interface Serial1/0
ip address 12.1.1.1 255.255.255.0
mpls ip
serial restart-delay 0
clock rate 1008000
!
interface Serial1/1
ip address 13.1.1.1 255.255.255.0
mpls ip
serial restart-delay 0
clock rate 1008000
!
router rip
version 2
network 1.0.0.0
network 12.0.0.0
network 13.0.0.0
no auto-summary
=======================================================================================
R2的配置:
!
no aaa new-model
ip source-route
ip cef
!
!
!
!
no ip domain lookup
ip vrf A-company
rd 2:2
route-target export 42:42
route-target import 24:24
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.0
!
interface Loopback1
no ip address
!
interface FastEthernet0/0
ip address 24.24.24.2 255.255.255.0
shutdown
duplex full
!
interface Serial1/0
ip address 12.1.1.2 255.255.255.0
mpls ip
serial restart-delay 0
!
interface Serial1/1
ip vrf forwarding A-company
ip address 24.1.1.2 255.255.255.0
serial restart-delay 0
!
!
router rip
version 2
network 2.0.0.0
network 12.0.0.0
network 223.0.0.0
no auto-summary
!
router bgp 1
no synchronization
bgp router-id 2.2.2.2
bgp log-neighbor-changes
redistribute rip
neighbor 3.3.3.3 remote-as 1
neighbor 3.3.3.3 **-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
address-family ipv4 vrf A-company
redistribute connected
redistribute static
no synchronization
network 0.0.0.0
exit-address-family
!
ip forward-protocol nd
ip route vrf A-company 0.0.0.0 0.0.0.0 24.1.1.4
no ip http server
no ip http secure-server
!
===========================================================================================
R3的配置:
!
!
!
!
no ip domain lookup
ip vrf A-company
rd 3:3
route-target export 24:24
route-target import 42:42
!
ip vrf B
description branch-of-companyA
rd 3366:3366
route-target export 24:24
route-target import 42:42
!
no ipv6 cef
!
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
ip address 13.1.1.3 255.255.255.0
mpls ip
serial restart-delay 0
!
interface Serial1/1
ip vrf forwarding A-company
ip address 35.1.1.3 255.255.255.0
serial restart-delay 0
!
interface Serial1/2
ip vrf forwarding B
ip address 36.1.1.3 255.255.255.0
serial restart-delay 0
!
router rip
version 2
network 3.0.0.0
network 13.0.0.0
network 222.0.0.0
no auto-summary
!
address-family ipv4 vrf A-company
redistribute bgp 1 metric transparent
network 35.0.0.0
no auto-summary
exit-address-family
!
router bgp 1
no synchronization
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 1
neighbor 2.2.2.2 **-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
exit-address-family
!
address-family ipv4 vrf B
redistribute connected
redistribute static
no synchronization
exit-address-family
!
address-family ipv4 vrf A-company
redistribute connected
redistribute static
no synchronization
exit-address-family
!
ip forward-protocol nd
ip route vrf A-company 5.5.5.0 255.255.255.0 35.1.1.5
ip route vrf B 6.6.6.0 255.255.255.0 36.1.1.6
no ip http server
no ip http secure-server
===========================================================================================
R4、R5、R6这三个CE都是一条默认路由指向PE:
例如R4上是ip route 0.0.0.0 0.0.0.0 24.1.1.2
===========================================================================================
|
本帖子中包含更多资源
您需要 登录 才可以下载或查看,没有账号?立即注册
x
|