幽林银魂 发表于 2013-6-19 13:35:26

mpls 问题细化



R1---R2-R3-R4---R5

####R1####                                                               
interface Loopback0                                                
ip address 192.168.1.1 255.255.255.0
!         
interface Serial0/0
ip address 12.1.1.1 255.255.255.0
serial restart-delay 0
no dce-terminal-timing-enable
no ip http server
no ip http secure-server
ip route 192.168.2.0 255.255.255.0 12.1.1.2
!   

###R2##
!         
ip vrf njm
rd 100:1
route-target export 100:1
route-target import 100:1

!         
!         
!         
interface Loopback0
ip address 2.2.2.2 255.255.255.0
ip ospf network point-to-point
!         
interface Serial0/0
ip vrf forwarding njm
ip address 12.1.1.2 255.255.255.0
serial restart-delay 0
no dce-terminal-timing-enable
!         
interface Serial0/1
ip address 23.1.1.1 255.255.255.0
mpls ip
serial restart-delay 0
!         
router ospf 1
log-adjacency-changes
network 2.2.2.0 0.0.0.255 area 0
network 23.1.1.0 0.0.0.255 area 0
!         
router bgp 100
no synchronization
bgp router-id 2.2.2.2
bgp log-neighbor-changes
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 **-source Loopback0
no auto-summary
!      
address-family vpnv4
neighbor 4.4.4.4 activate
neighbor 4.4.4.4 send-community extended
exit-address-family
!      
address-family ipv4 vrf njm
redistribute static
no synchronization
exit-address-family
!         
no ip http server
no ip http secure-server
ip route vrf njm 192.168.1.0 255.255.255.0 12.1.1.1
!         

####R3####
!
ip cef
no ip domain lookup
!         
!               
interface Loopback0
ip address 3.3.3.3 255.255.255.0
ip ospf network point-to-point
!         
interface Serial0/0
ip address 23.1.1.2 255.255.255.0
mpls ip
serial restart-delay 0
no dce-terminal-timing-enable
!         
interface Serial0/1
ip address 34.1.1.1 255.255.255.0
mpls ip
serial restart-delay 0
no dce-terminal-timing-enable
router ospf 1
log-adjacency-changes
network 3.3.3.0 0.0.0.255 area 0
network 23.1.1.0 0.0.0.255 area 0
network 34.1.1.0 0.0.0.255 area 0

####R4####
ip cef
no ip domain lookup
!         
ip vrf njm
rd 100:1
route-target export 100:1
route-target import 100:1
!         
!            
interface Loopback0
ip address 4.4.4.4 255.255.255.0
ip ospf network point-to-point
!         
interface Serial0/0
ip address 34.1.1.2 255.255.255.0
mpls ip
serial restart-delay 0
no dce-terminal-timing-enable
!         
interface Serial0/1
ip vrf forwarding njm
ip address 45.1.1.1 255.255.255.0
serial restart-delay 0
no dce-terminal-timing-enable
!         
!         
router ospf 1
log-adjacency-changes
network 4.4.4.0 0.0.0.255 area 0
network 34.1.1.0 0.0.0.255 area 0
!         
router bgp 100
no synchronization
bgp router-id 4.4.4.4
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 **-source Loopback0
no auto-summary
!      
address-family vpnv4
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community extended
exit-address-family
!      
address-family ipv4 vrf njm
redistribute static
no synchronization
exit-address-family
!         
no ip http server
no ip http secure-server
ip route vrf njm 192.168.2.0 255.255.255.0 45.1.1.2
   
####R5###

!         
!         
interface Loopback0
ip address 192.168.2.1 255.255.255.0
!         
interface Serial0/0
ip address 45.1.1.2 255.255.255.0
serial restart-delay 0
no dce-terminal-timing-enable
!         
interface Serial0/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!         
interface Serial0/2
no ip address
shutdown
!         
no ip http server
no ip http secure-server
ip route 192.168.1.0 255.255.255.0 45.1.1.1

阿宝和佳佳 发表于 2013-6-26 22:16:29

-woniu1--woniu1--woniu1-
页: [1]
查看完整版本: mpls 问题细化