CCNP 路由实验求助
拓扑图
R1 (S1/1)-------(S1/0)R2(S1/1) -------(S1/0) R3(S1/1) ---------- (S1/0)R4
配置如下,在R2,R3,R4上采用EIGRP 协议 ,在R2上配置一条静态路由,然后重分发到EIGRP中,
然后再R4上能学到这个路由,但是无法ping通12.12.12.1 这个地址。
R1的S1/1地址 12.12.12.1/24
R2的S1/0地址12.12.12.2/24
现在需求是 在R4上能ping 通 12.12.12.1 这个地址,为什么能学到路由 缺无法ping通地址?
R2配置
interface Loopback0
ip address 2.2.2.2 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
ip address 12.12.12.2 255.255.255.0
serial restart-delay 0
!
interface Serial1/1
ip address 23.23.23.2 255.255.255.0
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
router eigrp 90
redistribute static // 做一个静态重分发
network 2.2.2.0 0.0.0.255
network 12.12.12.0 0.0.0.255
network 23.23.23.0 0.0.0.255
no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 12.12.12.1 // 在R2上有一个到R1的默认路由
no ip http server
!
!
!
================
R4的配置
能学到这个静态路由
4#show ip rou
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 34.34.34.3 to network 0.0.0.0
34.0.0.0/24 is subnetted, 1 subnets
C 34.34.34.0 is directly connected, Serial1/0
2.0.0.0/24 is subnetted, 1 subnets
D 2.2.2.0 via 34.34.34.3, 01:10:36, Serial1/0
3.0.0.0/24 is subnetted, 1 subnets
D 3.3.3.0 via 34.34.34.3, 02:15:42, Serial1/0
4.0.0.0/24 is subnetted, 1 subnets
C 4.4.4.0 is directly connected, Loopback0
23.0.0.0/24 is subnetted, 1 subnets
D 23.23.23.0 via 34.34.34.3, 02:15:42, Serial1/0
12.0.0.0/24 is subnetted, 1 subnets
D 12.12.12.0 via 34.34.34.3, 01:10:36, Serial1/0
D*EX 0.0.0.0/0 via 34.34.34.3, 00:02:30, Serial1/0
==
interface Loopback0
ip address 4.4.4.4 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
ip address 34.34.34.4 255.255.255.0
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
router eigrp 90
network 4.4.4.0 0.0.0.255
network 34.34.34.0 0.0.0.255
no auto-summary
!
ip classless
no ip http server
--============
R3
interface Loopback0
ip address 3.3.3.3 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
ip address 23.23.23.3 255.255.255.0
serial restart-delay 0
!
interface Serial1/1
ip address 34.34.34.3 255.255.255.0
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
router eigrp 90
network 3.3.3.0 0.0.0.255
network 23.23.23.0 0.0.0.255
network 34.34.34.0 0.0.0.255
no auto-summary
!
ip classless
no ip http server
路由是双向的,R1上有没有回到R4的路由呢~ 那在R1上有配置回来的路由吗?
通信时双向的过程,R4上有去往12.12.12.0的路由,但是R1上也要有回来的路由! LY姐俺们思路一样嘛~-woniu2- R1 是没有去R4的路由, 但是我不明白, 弄一个这个 redistribute static
有什么用呢??
R4能学到去R1的路由, 但是却又ping不通??如果R1是一家运营商,他当然不会把路由指到R2,或者R4。 debug ip routing,在R1上开起来就能看到原因了。 redistribute static是把R2的静态路由都通告给其他OSPF邻居,让他们也学到这些静态路由。
R4有R1的路由说明R4知道如何去R1,但是如果R1不知道如何去R4的话,R4给他发的ping包R1是回不去的,R4也收不到R1发回的ping包,所以R4就认为R1ping不通。
如果运营商给你分配这个地址的话,他肯定也会在路由表中加一条到那里的路由的~ 不通的原因是 R1没有到R4的路由,加上就好了。
但是 如果R1是一家运营商,他当然不会把路由指到R2,或者R4。
他不会给每个用户都指路由。
这个怎么解决?? 运营商 会加入?? 联通电信 有成千上万个用户?
每个用户都会加入?? 根据楼主的话,我是这样理解的:
楼主认为如果R1为电信运营商,那么R2的S1/0连接的是运营商,S1/1连接的是自己的内网。
这种情况下,则在R2上应该有NAT进行转换,同时R2上还要配置一条默认路由。那么题目要求配的静态路由就应该是默认路由了,这样才能上百度,谷歌等网站。同时通过重分布把默认路由重分布到EIGRP里的其他路由器。
至于R1则只需要知道怎么到达R2的S1/0就可以了,而不用了解R2后面的私网,因为是直连,所以这个就没问题了。
这是我对楼主问题的理解,不知道有没理解错误。