zhouzerong 发表于 2008-6-15 11:05:42

vlan之间的通信问题

今天用Dynamipus做了VLAN实验,但为什么总是V2和V3之间的PC不能通信呢?哪位大哥给讲解一下…………


一台路由器,三台交换机,四台PC


各个机器的 配置如下:
R9:
Current configuration : 1282 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
!
!
!         
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex half
!
interface FastEthernet0/0.1
encapsulation dot1Q 1 native
no cdp enable
!
interface FastEthernet0/0.2
encapsulation dot1Q 2
ip address 172.16.20.1 255.255.255.0
no cdp enable
!
interface FastEthernet0/0.3
encapsulation dot1Q 3
ip address 172.16.30.1 255.255.255.0
no cdp enable
!
interface Serial1/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/1
ip address 192.168.10.1 255.255.255.0
serial restart-delay 0
clock rate 64000
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
ip classless
no ip http server
!
!
no cdp run
!

SW1:

Current configuration : 1524 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
memory-size iomem 5
no aaa new-model
ip subnet-zero
!
!
ip cef
!
!
no ip domain lookup
no ftp-server write-enable
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
!
interface FastEthernet0/1
no ip address
shutdown
!
interface FastEthernet0/2
no ip address
shutdown
!
interface FastEthernet0/3
no ip address
shutdown
!
interface FastEthernet0/4
no ip address
shutdown
!
interface FastEthernet0/5
no ip address
shutdown
!
interface FastEthernet0/6
no ip address
shutdown
!
interface FastEthernet0/7
no ip address
shutdown
!
interface FastEthernet0/8
no ip address
shutdown
!
interface FastEthernet0/9
no ip address
shutdown
!
interface FastEthernet0/10
no ip address
shutdown
!
interface FastEthernet0/11
no ip address
shutdown
!
interface FastEthernet0/12
no ip address
shutdown
!
interface FastEthernet0/13
switchport mode trunk
no ip address
!
interface FastEthernet0/14
switchport mode trunk
no ip address
!
interface FastEthernet0/15
switchport mode trunk
no ip address
!
interface Vlan1
ip address 172.16.10.2 255.255.255.0
!
ip default-gateway 172.16.10.1
ip http server
ip classless
!
!
!
no cdp run
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
logging synchronous
transport preferred all
transport output all
line aux 0
transport preferred all
transport output all

SW3:

Current configuration : 1530 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
memory-size iomem 5
no aaa new-model
ip subnet-zero
!
!
ip cef
!
!
no ip domain lookup
no ftp-server write-enable
!
!
!
!
interface FastEthernet0/0
switchport access vlan 2
no ip address
!
interface FastEthernet0/1
switchport access vlan 3
no ip address
!
interface FastEthernet0/2
no ip address
shutdown
!
interface FastEthernet0/3
no ip address
shutdown
!
interface FastEthernet0/4
no ip address
shutdown
!
interface FastEthernet0/5
no ip address
shutdown
!
interface FastEthernet0/6
no ip address
shutdown
!
interface FastEthernet0/7
no ip address
shutdown
!
interface FastEthernet0/8
no ip address
shutdown
!
interface FastEthernet0/9
no ip address
shutdown
!
interface FastEthernet0/10
no ip address
shutdown
!
interface FastEthernet0/11
no ip address
shutdown
!
interface FastEthernet0/12
no ip address
shutdown
!
interface FastEthernet0/13
switchport mode trunk
no ip address
!
interface FastEthernet0/14
no ip address
shutdown
!
interface FastEthernet0/15
no ip address
shutdown
!
interface Vlan1
ip address 172.16.10.3 255.255.255.0
!
ip default-gateway 172.16.10.1
ip http server
ip classless
!
!
!
no cdp run
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
logging synchronous
transport preferred all
transport output all
line aux 0
transport preferred all
transport output all
line vty 0 4
!         
end
SW4:
Current configuration : 1530 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
memory-size iomem 5
no aaa new-model
ip subnet-zero
!
!
ip cef
!
!
no ip domain lookup
no ftp-server write-enable
!
!
!
!
interface FastEthernet0/0
switchport access vlan 2
no ip address
!
interface FastEthernet0/1
switchport access vlan 3
no ip address
!
interface FastEthernet0/2
no ip address
shutdown
!
interface FastEthernet0/3
no ip address
shutdown
!
interface FastEthernet0/4
no ip address
shutdown
!
interface FastEthernet0/5
no ip address
shutdown
!
interface FastEthernet0/6
no ip address
shutdown
!
interface FastEthernet0/7
no ip address
shutdown
!
interface FastEthernet0/8
no ip address
shutdown
!
interface FastEthernet0/9
no ip address
shutdown
!
interface FastEthernet0/10
no ip address
shutdown
!
interface FastEthernet0/11
no ip address
shutdown
!
interface FastEthernet0/12
no ip address
shutdown
!
interface FastEthernet0/13
no ip address
shutdown
!
interface FastEthernet0/14
switchport mode trunk
no ip address
!
interface FastEthernet0/15
no ip address
shutdown
!
interface Vlan1
ip address 172.16.10.4 255.255.255.0
!
ip default-gateway 172.16.10.1
ip http server
ip classless
!
!
!
no cdp run
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
logging synchronous
transport preferred all
transport output all
line aux 0
transport preferred all
transport output all
line vty 0 4
!
end

PC3;
!
interface FastEthernet0/0
ip address 172.16.20.2 255.255.255.0
no ip route-cache
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
no ip route-cache
shutdown
duplex auto
speed auto
!
ip default-gateway 172.16.20.1
ip http server
ip classless
!
PC4:

interface FastEthernet0/1
ip address 172.16.30.2 255.255.255.0
duplex auto
speed auto
!
ip default-gateway 172.16.30.1
ip http server
ip classless
!
PC5;

interface FastEthernet0/0
ip address 172.16.20.3 255.255.255.0
no ip route-cache
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
no ip route-cache
shutdown
duplex auto
speed auto
!
ip default-gateway 172.16.20.1
ip http server
ip classless
!

PC6:

interface FastEthernet0/1
ip address 172.16.30.3 255.255.255.0
duplex auto
speed auto
!
ip default-gateway 172.16.30.1
ip http server
ip classless
!

广播风暴 发表于 2008-6-15 17:35:03

2个SW的网关地址是172.16.10.1 可是你Router 9上的 .1子接口没给配IP地址 当然不通了~~~

zhouzerong 发表于 2008-6-15 22:10:38

回复 2# 的帖子

仅仅就因为这一个问题吗 ?
还有其他的吗?

广播风暴 发表于 2008-6-16 10:39:43

其他 ~~没看出来~~~

matthew 发表于 2008-6-16 13:18:04

我画的拓扑?

周卿同学?(*^__^*) 嘻嘻……

matthew 发表于 2008-6-16 13:23:34

周同学的配置。。。很乱。。。

不通是正常的。。。

另外。。。以后做试验最好不要用模拟器

模拟器是拿来练手的

SPOTO有真实机器

以后常来SPOTO哦

beHacker 发表于 2008-6-27 07:17:30

シュオシフア、ナゲォゴヤオヅオチョウヨウヅオチョウ~
页: [1]
查看完整版本: vlan之间的通信问题